Design Science: How Science Communicates
日本語版ホーム ソリューション ご購入(料金・ご注文) サポート リファレンス ダウンロード サイトライセンス Design Science
サポート » MathType対応ソフト

MathType 対応ソフト

特定のアプリケーションやweb サイトでMathType がどのように機能するかに関する最新の情報源です。ここではとりわけMathType ユーザーに人気の高いアプリケーションを取り上げます。

Microsoft Word

Microsoft Word とMathType は、一体型のインターフェイスとなるため、Microsoft Word にあるツールバー上のボタンをクリックするだけで、数式が挿入できます。
さらに、数式に番号を付けたり、文書中のすべての数式をフォーマットしたり様々なタスクを行なうことができます。
Word はMicrosoft Office を構成するワード・プロセッサです。Word は一般的なリンク機能の他にOLE (オブジェクト・リンキング&エンベディング)と呼ばれる埋め込みオブジェクトに対応します。もとよりMathType 数式はOLE オブジェクトであるため、MathType とWord の相性の良さは抜群です。MathType とWord で次のことが行えます:

  • Word に数式を追加:Word 上のMathType ツールバー、メニューあるいはリボン・タブコマンド類を使用して、挿入ポイントや個別の文章中に数式を挿入できます。あるいは、MathTypeからWordへ数式や数学記号を直接ドラッグ&ドロップするかコピー&ペーストが行えます。

  • Word の数式を編集:OLEにはMathType が数式作成に用いられた記録が残るため、ダブルクリックするだけで、MathType で数式を開きます。変更終了後、ウィンドウを閉じることで、Word 文書内の数式を更新することになります。

  • Wordに手書きの数学を挿入:Windows 7 以降のOS を使用している場合、Windows 数式入力パネル、タブレットPC、ディジタイズ用タブレット、マウスを使って、簡単に手書きの数式を入力できます。

  • 数式の番号と参照:新しい数式を加えると、自動的に数と参照が更新します。

  • 文書中のすべての数式のフォントおよびサイズを変更:文書中のすべての数式のフォントおよびサイズを変更できます。これは数式を残りの文書のスタイルと一致させる必要がある場合、とても便利です。

  • 見栄え良く、アクセシブルな数学Web ページを作成:Word 上のMathType の「MathPage の出力」コマンドは、専門的な文書をWeb 上に掲載することを簡単にします。Word に直接LaTeX入力し、クリックでMathType 数式に切り替えられます。

  • 文書中の数式および数式番号をすべて参照:作業内容をチェックする必要がある場合、MS Word 上のMathType の数式参照機能を使って、全ての数式を閲覧できます。

  • 文書中の全ての数式をTeX/LaTeX、MathML、EPS、GIF、WMF の形式で出力:別のアプリケーションやWeb ページで、Word にある数式のイメージを使用する必要がある場合は、コマンドひとつで数式すべてをイメージに変換できます。

Microsoft PowerPoint

PowerPoint とMathTypeは、一体型のインターフェイスとなるため、PowerPoint にあるツールバー上のボタンをクリックするだけで、数式が挿入できます。PowerPoint は、Microsoft Office を構成するプレゼンテーション用アプリケーションです。PowerPoint は、一般的なリンク機能の他にOLE (オブジェクト・リンキング&エンベディング)と呼ばれる埋め込みオブジェクトに対応します。
もとよりMathType数式はOLE オブジェクトであるため、MathType とPowerPoint の相性の良さは抜群です。MathType とPowerPoint で次のことが行えます:

  • PowerPoint に数式を追加:PowerPoint 上のツールバーとメニューのコマンドを使用して、スライド上に数式を挿入できます。また、MathType からPowerPoint へ数式や数学記号をドラッグ&ドロップ、あるいはコピー&ペーストもできます。

  • PowerPoint でテキストと数式をアニメート:数式をスライドに現われるようにプログラムできます。

  • PowerPoint から数式をコピー:PowerPoint からMathType へ数式をドラッグ&ドロップ、もしくはコピー&ペーストし、MathType で新規書類として、編集や使用ができます。

  • PowerPoint 中の数式を編集:OLE にはMathType が数式作成に用いられた記録が残るため、ダブルクリックするだけで、MathType で数式を開きます。変更終了後、ウィンドウを閉じることで、PowerPoint 書類内の数式を更新することになります。

Apple iWork

Apple iWork の「MathType 数式」挿入コマンドの使用によりApple iWork'09 に簡単にMathType 数式の挿入ができます。iWork の初期バージョンをお使いの場合、アップグレードを強くお勧めします。iWork は、ワード・プロセッサ、プレゼンテーション、スプレッドシートのアプリケーションで構成されます。iWork とMathType を使用して次のことが行えます:

  • 3つのiWork構成アプリケーションすべてに数式を加えます:すなわちPages(ワード・プロセッサ)、Keynote(プレゼンテーション)、Numbers(スプレッドシート)。

  • iWork の中の数式を編集します:数式の作成にMathType を使用したことをiWork が記憶しているので、ダブルクリックするだけで、MathType の中の数式を開き、編集できます。変更終了後、ウィンドウを閉じることで、iWork の中の数式が更新されます。数式エディタやMathType 数式を含むMac用Microsoft Office の文書も読み込めます

iBooks Author

iBooks Author の「MathType 数式を挿入」コマンドの使用により、簡単にMathType 数式を挿入ができます。数式の編集も、ただダブルクリックするだけの簡単さです。
iBooks Author はiPad 用の電子書籍(ebooks)を作成できるMac用のアプリケーションです。MathType と一体型のインターフェイスのため、iBooks Author への数式の挿入はとても便利です。MathType およびiBooks Author で、次のことが行えます:

  • iBooks Author に数式を追加:iBooks Author 上の「MathType 数式」挿入コマンドによりMathType 数式の挿入がとても簡単に行えます。

  • iBooks Author の中の数式を編集:ダブルクリックと同じくらい簡単です。

  • Apple Pages からの数式を含んだ文書をコピー:Pages (iWork '09構成アプリケーションの一つ)を使って仕事をしていたり、同僚からそうした文書を送った場合、再度文書を入力する必要はないので、時間の節約になります。

  • 読み上げ可能な数学表記を伴うアクセシブルなiBook を作成:Apple 社のVoiceOver スクリーン・リーダ・ソフトウェアによって、視覚障害をもった人々にもアクセス可能なように、音読されるテキストに各数式を関連付けられます。

Adobe InDesign

MathType からInDesign に、EPS 形式の画像イメージとして、数式を挿入することができます。またEPS は、InDesign が最も数式をきれいに表示することが可能な保存形式です。MathType とInDesign で次のことが行えます:

  • InDesign に数式を追加:InDesign 書類に取り込めるEPS イメージとしてMathType 数式を保存することができます。またMathType からの数式および数学記号を直接InDesign にコピーして、貼り付けることもできます。

  • InDesign 内の数式を編集:InDesign 内で配置コマンドを使用すると、数式へのリンクが保存されます。変更終了後、MathType のオリジナルのEPS を開いて、編集すると、MathTypeウィンドウを閉じた際に、InDesign 内の数式が更新されます。

  • InDesign にMathType 数式を有したWord 文書をインポート:数式を有したWord 文書は、InDesign に数式の並びを乱さずに、適切に文書と数式を直接配置できます。

Maple

Maple は入出力の両方でMathML を使用できる人気の数式処理システムです。MathType でMaple 用のMathML を作成したり、Maple 内の既存の数式を使用することも簡単です。MathType とMaple で次のことが行えます:

  • Maple に数式を追加:MathType でMathML として作成した数式を、Maple が認識するMathML としてドラッグ&ドロップあるいはコピー&ペーストできます。

  • Maple から数式をコピー:Maple からMathType に数式をコピー&ペーストできます。MathType で、その数式を編集し、MathType 数式ライブラリーに加えたり、Maple の新規の書類の中でそれを使用できます。

Mathematica

Mathematica とともに、MathType を使用して、数学の未知の領域を共有しましょう。Mathematica からワード・プロセッサ、プレゼンテーション、他の数式処理システム、オンライン学習システムなど何百ものアプリケーションやWeb サイトに数式をコピーする際に、MathType を使用することにより、時間の節約やエラー回避に役立ちます。MathType とMathematica で次のことが行えます:

  • Mathematica に数式を追加:MathType でMathML として作成した数式を、Mathematica が認識するMathML としてドラッグ&ドロップあるいはコピー&ペーストできます。

  • Mathematica から数式をコピー:Mathematica からMathML としてMathType に数式をコピーして貼り付けできます。Mathematica からMathType に数式をコピー&ペーストできます。MathType で、その数式を編集し、MathType 数式ライブラリーに加えたり、Mathematica の新規の書類の中でそれを使用できます。

MATLAB

MathType をMATLAB と使用すると、タイトルの注釈や、他の注釈を挿入する容易な方法として役立ちます。ただしMathType 数式はMATLAB の中での計算に使用することができません。MATLAB は、技術的に高度なコンピュータ処理言語で、アルゴリズム開発、データ可視化、データ分析、数値計算のためのインタラクティブな環境です。MathType とMATLAB で次のことが行えます:

  • MATLAB の関数ファイルに数式を追加:数式や数学記号をMathType から直接MATLAB の関数ファイルにコピー&ペーストできます。

  • MATLAB 関数ファイルからの数式をコピー:MATLAB の関数ファイルからMathType に数式をコピー&ペーストし、それを編集したり、新規書類内で使用できます。

Mathcad Prime

Mathcad と一緒にMathType を使用すると、絵、図表、グラフにラベルを付ける簡単な方法として役立ちます。ただし、MathType では、Mathcad の中で計算に使用される数式は作成できません。MathType とMathcad で次のことが行えます:

  • 注釈としてMathcad に数式を追加:Mathcad ワークシートにMathType 数式を加えることができます。これは数学の標準記法で注釈されたグラフなどをワークシートに掲示したい場合に有用です。

  • Mathcad から数式をコピー:Mathcad からMathType に数式をコピー&ペーストし、新規書類の中でそれを編集、あるいは使用できます。

Mathcad ワークシートの中、あるいは他(Word 文書など)のところで使用するため、Mathcad 形式のファイルをMathType 数式に変換することに関しては、今のところ対応していないことに注意してください。

OpenOffice

MathType はOpenOffice と一緒に使用でき、OpenOffice 文書、プレゼンテーション、スプレッドシートに数式を挿入することができます。OpenOffice はWindows の汎用リンクの他にOLE(オブジェクト・リンキング&エンベディング)と呼ばれる埋め込みオブジェクトに対応するオープン・ソース・オフィス・パッケージです。もとよりMathType 数式はOLE オブジェクトであるため、MathType とOpenOffice の相性は、英語(1 バイト言語)環境においては、申し分ありませんが、日本語環境では、括弧が文字化けを起こす問題が確認されています。OpenOffice とMathType で次のことが行えます:

  • OpenOffice に数式を追加:OpenOffice の「オブジェクトを挿入」メニュー・コマンドを使用して、挿入ポイントに数式を挿入できます。また、MathType から直接OpenOffice へ数式や数学記号をドラッグ&ドロップ、もしくはコピー&ペーストできます。(日本語環境では、括弧を含む数式の場合、文字化けが生じます)

  • OpenOffice の中の数式を編集:OLE にはMathType が数式作成に用いられた記録が残るため、ダブルクリックするだけで、MathType で数式を開きます。変更終了後、ウィンドウを閉じることで、OpenOffice 文書内の数式を更新することになります。(日本語環境では、括弧を含む数式の場合、OpenOffice の文書上で文字化けが生じます)

QuarkXPress

MathType からQuarkXPress に、EPS 形式の画像イメージとして、数式を挿入することができます。またEPS はQuarkXPress が最も数式をきれいに表示することが可能な保存形式です。MathType とQuarkXPress で次のことが行えます:

  • QuarkXPress のプロジェクトに数式を追加:EPSファイルは高解像度出力に最良の選択です。

  • QuarkXPress のプロジェクト中の数式を編集:数式を書類に埋め込むことによって、MathType で簡単に編集することができます。

Copyright (C) 1996- Design Science. All rights reserved.
-冒頭に戻る-